Abkündigung Support für FrameScript/ElmScript November 2023

Sehr geehrte Damen und Herren,

im Jahr 2000 begann ich für Firmen in Europa Lizenzen des FrameMaker-Plug-ins FrameScript/ElmScript aus den USA zu beschaffen. Das Plug-in ermöglicht die Programmierung von Skripten zur Steuerung von FrameMaker, was Funktionen ermöglichte, für die man bis dahin in C programmieren musste.

Mit der Version FrameMaker 10 im Jahr 2011 bekam das Produkt eine eigene Skriptsprache: „ExtendScript“.

Ich empfehle daher allen Anwendern von FrameScript/ElmScript, die vorhandenen Lösungen auf ExtendScript umzustellen. Dazu wird dann kein externes Plug-in mehr benötigt. Dabei unterstützen kann Sie 4XScripts, betrieben von Ute Mitschke und Klaus Göbel, die beide seit vielen Jahren Adobe-Technologiepartner sind. Verschaffen Sie sich gerne einen Überblick mit der teilweise kostenlosen Skriptsammlung, die Sie auf https://4xscripts.com/ unter „Add-ons“ finden.

Weil zudem die Nachfrage nach FrameScript deutlich abgenommen hat, werde ich Lizenzbestellungen nur noch bis Ende November 2023 annehmen.

Wenn Sie weiter bei FrameScript/ElmScript bleiben wollen, stelle ich Ihnen gerne eine aktuelle Lizenzübersicht zur Verfügung, in der Ihre aktuellen Lizenzen der Versionen 6 und 7 aufgeführt sind. Damit können Sie sich direkt an ElmSoft http://framescr.com/ für Upgrades auf zukünftige Versionen wenden.

Vielen Dank für Ihr Vertrauen und weiterhin Erfolg bei der Automation Ihrer Dokumentationsprozesse.

  • Michael Müller-Hillebrand

PS: Von Version 6 aus können Sie auf Version 7 zu reduzierten Kosten wechseln.

Veröffentlicht unter Allgemein, FrameScript | Kommentare deaktiviert für Abkündigung Support für FrameScript/ElmScript November 2023

FrameMaker 2022 wird unterstützt

Für dieses neueste Release von FrameMaker ist eine neue Fassung von ElmScript verfügbar, die Sie ab sofort bei den Downloads finden.

Weiterhin gilt: Wenn Sie FrameMaker 2020 einsetzen, müssen Sie auf 16.0.3 aktualsieren, diese Fassung ist mit den Versionen 16.0.1 und 16.0.2 nicht lauffähig!

Veröffentlicht unter FrameScript, Versionen | Kommentare deaktiviert für FrameMaker 2022 wird unterstützt

FrameMaker 2020 16.0.3

Für dieses Patch-Release ist eine neue Fassung von ElmScript erforderlich, die Sie ab sofort bei den Downloads finden.

Diese Fassung ist mit den Versionen 16.0.1 und 16.0.2 nicht lauffähig!

Veröffentlicht unter FrameScript, Versionen | Kommentare deaktiviert für FrameMaker 2020 16.0.3

FrameMaker 2020 (a.k.a. 16)

Offenbar ist im Juli 2020 eine neue FrameMaker-Version erschienen, woran sich die Frage anschließt, wann es die passende Version von FrameScript/ElmScript geben wird. Dazu dieser Zwischenstand:

Hello Michael,

We are working on the new release. Unless something unusual happens, it will be a free release. I hope to have a beta version out next week.

Frank Elmore
Project leader for FrameScript

Eigentlich sollte es mich nicht erstaunen, aber FrameMaker ist auf der Webseite von Adobe immer noch schwer (oder gar nicht?) über die Navigation zu finden. Es gibt die Volltextsuche, und auf der Produktseite auch auch einen Link „Version comparison“: http://www.adobe.com/go/learn_fm_version_comp_en – und dort heißt die aktuelle Version einfach nur „Latest version“.

Update 10.08.2020

We have a beta FrameScript 7 for FrameMaker 2020 ready for download on our website. Check out the Downloads page. It is part of the standard eval version.

This will be a free upgrade.

https://framescr.com/wb/downloads.html

Update 01.03.2021

Die Downloads enthalten jetzt die neue Fassung von FrameScript Version 7 einschließlich der Unterstützung von FrameMaker 2020.

Veröffentlicht unter FrameScript | Kommentare deaktiviert für FrameMaker 2020 (a.k.a. 16)

FrameScript 7 verfügbar

Die neue Version von ElmScript/FrameScript ist verfügbar, jetzt in zwei Versionen: 32 Bit und 64 Bit. Letztere natürlich nur für FrameMaker 2019.

BTW, due to the excessive amount of work required to produce this version, it will be released as FrameScript 7. This means that there will be an update cost associated this version. Existing FrameScript 6 customers can upgrade for the usual upgrade cost. FrameScript 6 will, of course, still work for FM versions 6 through FM 2017. However, FM 2019 will require FrameScript 7.

Frank Elmore
Project leader for FrameScript

Veröffentlicht unter Versionen | Kommentare deaktiviert für FrameScript 7 verfügbar